Riak TS backup procedure

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Riak TS backup procedure

Daniel Brandt
Hi!

I set up a new RiakTS cluster and decided to seed it with the data from my experimental cluster by following the currently recommended backup procedure (http://docs.basho.com/riak/kv/2.1.4/using/cluster-operations/backing-up/) and then restoring it using these instructions: http://docs.basho.com/riak/kv/2.1.4/using/cluster-operations/changing-cluster-info/#clusters-from-backups.

The procedure worked without a hitch and the cluster is up and running, but when I connect my app servers to the new cluster they give me errors saying my tables are not activated. 

For fun I decided to activate a table (with 'riak-admin bucket-type activate') thinking the tables might be defined but not activated (which admittedly seems strange after restoring from backup), but I still got the same error messages from the appservers saying the table was not activated. 

I then tried to recreate the table but got an error saying the table is already activated. Catch 22.

Two observations: 
1) When restoring a RiakTS cluster from backups made according to the RiakKV procedure, the table definitions appear to be lost.
2) Is it reasonable to be able to use riak-admin to activate a table by name even if there's no table definition attached to it?

I'm still experimenting, so there's no panic on my end, but I sure would like to have an idea about how to create reliable backups for RiakTS before moving on to production use...

Regards,
Daniel

_______________________________________________
riak-users mailing list
[hidden email]
http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
Loading...