Make Riak use different Erlang version than that included in the .deb package

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Make Riak use different Erlang version than that included in the .deb package

Jeremy Raymond

I'm using Riak installed from riak_0.14.0-1_amd64.deb but am having a problem with an Erlang reduce function I wrote because it used calendar:iso_week_number/1 which isn't available in R13B04 which is bundled with the .deb package. Is there an easy way to configure Riak to use a different Erlang install (say installed at /usr/local/lib/erlang)?

- Jeremy

_______________________________________________
riak-users mailing list
[hidden email]
http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
Reply | Threaded
Open this post in threaded view
|

Re: Make Riak use different Erlang version than that included in the .deb package

Justin Sheehy
Hi, Jeremy.

If you build Riak from source, you'll end up with Riak using the
version of Erlang that you used to build it.  With a pre-packaged
version, it will use the Erlang that was used to make the packages.

Riak will be moving to a newer Erlang in upcoming releases, by the way.

-Justin



On Thu, May 12, 2011 at 4:00 PM, Jeremy Raymond <[hidden email]> wrote:

>
> I'm using Riak installed from riak_0.14.0-1_amd64.deb but am having a
> problem with an Erlang reduce function I wrote because it used
> calendar:iso_week_number/1 which isn't available in R13B04 which is bundled
> with the .deb package. Is there an easy way to configure Riak to use a
> different Erlang install (say installed at /usr/local/lib/erlang)?
> - Jeremy
>
> _______________________________________________
> riak-users mailing list
> [hidden email]
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>
>

_______________________________________________
riak-users mailing list
[hidden email]
http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com